
Determining if a PDF file can be used as an interactive form is a matter of visually 
examining the file and looking for the presence of form fields, or areas in the 
document where users are asked to provide some kind of information such as 
name, address, telephone number, or email address. Respondents might be asked 
to indicate a preference or status by checking a box. If you want users to be able 
to complete the form online, rather than resort to printing a paper copy in order to 
complete the form, then the form should be an accessible interactive form. 

With Adobe Acrobat X Pro, you can make interactive form fields accessible to vision 
impaired users and users with mobility challenges by adding properly encoded 
fillable fields to the PDF file. You can also structure the form in such a way that users 
can use the tab key to move between fields in a meaningful and logical sequence. 
In addition, entries in the Tooltip field property can provide users of assistive 
technology, such as screen readers, with additional information about the field or 
to provide instructions. These tooltips are read by screen readers for the blind and 
visually impaired. 

For example, using the Tooltip property value, you could add text to a check box on 
an RSVP that users would use to indicate their intention to attend an awards dinner. 
You can encode the checkbox so the screen reader user would hear “I plan to attend 
the awards dinner.” Without adding such alternate text to the check box’s tool tip 
property, a screen reader simply provides the name of the form field (Check Box 
1), its type (Check Box), and its state (Unchecked). Screen reader users would hear 
“Check Box Checked” or “Check Box Unchecked” depending upon whether or not 
the box had been checked. It would not be clear to users listening to the form with 
a screen reader that the checkbox indicates their intention to attend the event. This 
is true even if there is a visible label next to the checkbox which reads, “Check this 
box if you plan to attend the awards dinner.” You need to add the tooltip text to the 
checkbox or radio button properties.

Acrobat X Pro can detect and create the form fields automatically or you can 
manually create the necessary fields using Acrobat X Pro’s form editing tools. If you 
choose to have Acrobat automatically detect form fields, it will attempt to locate any 
labels that are adjacent to the form field or check box and use any labels it does find 
as the source for alternate text (called a tooltip in Acrobat).

Note: 	 This discussion limits itself to the accessibility issues involved with 
creating form fields with the Acrobat X Pro form tools. For a more 
detailed discussion of PDF forms including forms created with the 
Adobe LiveCycle Designer or the Adobe Digital Enterprise Platform 
Designer, refer to the Acrobat X Pro online help.
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PDF Form Fields
A PDF form created with Adobe Acrobat X Pro’s forms editing tools can contain the following types of fields:

•	 Text field. Lets the user type in text, such as name, address, or phone 
number. 

•	 Check box. Presents yes-or-no choices for individual items. If the form 
contains multiple check boxes, the user can typically select as many or 
few of these as needed

•	 Radio button. Presents a group of choices from which the user can select 
only one item from the group. All radio buttons with the same name work 
together as a group.

•	 List box. Displays a list of options the user can select. You can set a form 
field property  that enables the user to Shift-click or Control-click to select 
multiple items on the list.

•	 Combo box. Lets the user either choose an item from a pop-up menu or 
type in a value.

•	 Button. Initiates a change on the user’s computer, such as opening a file, 
playing a sound, or submitting data to a web server. These buttons can 
be customized with images, text, and visual changes triggered by mouse 
actions.Action buttons have a different purpose than radio buttons, which 
represent data choices made by the user.

•	 Digital signature field. Lets the user electronically sign a PDF document 
with a digital signature.

•	 Barcode. Encodes the input form selected fields and diplays it as a 
visual pattern that can be interpreted by decoding software or hardware 
(available separately). 

Use Acrobat to Detect and Create Interactive Form Fields

You can convert an existing electronic document (for example a Word, Excel, or PDF document) 
or scan a paper copy into Acrobat), and Acrobat will add interactive fields to the form. 

When you convert a document to an interactive form, Acrobat X Pro can detect the form fields 
in the document. In many instances, Acrobat will use the form field labels to name the field and 
provide a Tooltip. While the results are often acceptable, this is not a foolproof process. You will 
need to examine the document carefully to verify that Acrobat accurately detected the fields and 
labelled them properly.

Acrobat Form Wizard
You can use the Form Wizard in Adobe Acrobat X Pro to create  interactive forms from an 
existing electronic document (for example a Word, PDF, or Excel document) or  from a paper 
form that was placed in a scanner with the resulting image opened in Acrobat. 

•	 Open a PDF document using Adobe Acrobat X Pro. A quick examination 
of the document should indicate whether it is a form.
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•	 Display the Create Command in the Forms Task Panel.  The Forms Task 
Panel is under the Tools Pane . From the Acrobat X Pro menu, you can 
select View > Tools > Forms to expose the Forms Task Panel under the 
Tools Pane (See “Figure 1. Create Form Command in the Forms Task 
Panel” on page 3). The keyboard accelerator for displaying the Forms 
Task Panel is Alt + V + T + F. 

Figure 1.  Create Form Command in the Forms Task Panel 

•	 Select the Create command (Keyboard Shortcut is Shift + Ctrl + 7).  This 
displays the Create or Edit Form Dialog (See “Figure 2. Acrobat X Pro 
Create or Edit Form Dialog” on page 3). 

Figure 2.  Acrobat X Pro Create or Edit Form Dialog

•	 From the Create or Edit Form Dialog, select one of the following 
options and then follow the on-screen instructions. 
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•	 Use an existing file. This converts an existing electronic 
document (for example Word or PDF) to an interactive PDF form. 
To use the document that is currently on display, select “Next” 
and “Use the current document.” Select “Next” again. Acrobat 
automatically searches for and creates any form fields it detects, 
and places the document in Form Editing Mode. Acrobat informs 
you that it has entered Form Editing Mode. When you select “OK”, 
the document is displayed in Form Editing Mode  (See “Figure 3. 
Adobe Acrobat X Forms Editing Mode” on page 4).

•	 Scan a paper form. To scan a paper form and convert it to a PDF 
form. The form will be scanned, converted to PDF and Acrobat 
will search for and create any form fields it detects. The form is  
placed in Form Editing Mode (See “Figure 3. Adobe Acrobat X 
Forms Editing Mode” on page 4).

•	 Create a web form or survey from scratch or template. This 
creates an Online Form using Adobe Forms Central. Using Adobe 
Forms Central is not a topic that is addressed in this Best Practices 
Guide.

Note: 	 Using the Adobe LiveCycle Designer, included in Adobe Acrobat X Pro for 
Windows, to create accessible PDF forms is not a topic that is addressed in this 
Best Practices Guide.

Assuming you selected either the Use and Existing File or Scan a paper form options, Acrobat X 
Pro completes an analysis of the document, adds any form fields it may detect and places the  
PDF form in Forms Editing Mode. Your document will look similar to what is shown in “Figure 
3. Adobe Acrobat X Forms Editing Mode” on page 4. While in Forms Editing Mode,  you can 
add to, edit or delete the automatically created form fields (See “Forms Editing Mode” on page 
6).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It 
may have also created fields of the wrong type. You should verify the fields and field names on 
the form. You can select Add New Field on the Forms Editing toolbar to add more fields or right 
click on the form to add, edit, or delete fields.

Figure 3.  Adobe Acrobat X Forms Editing Mode
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Enter Forms Editing Mode Directly
If you don’t want to use the Form Wizard, you can open the file, and place the document in Form 
Editing Mode directly.

•	 From the Acrobat Menu. Select View > Tools > Forms and select the Edit 
command under the Forms Tool Pane (Keyboard shortcut is Shift + Ctrl 7). 
This displays the Add or Edit Form Fields dialog (See “Figure 4. Acrobat X 
Pro Add or Edit Form Fields Dialog” on page 5). 

Answering “Yes” to the Add or Edit Form Fields dialog question “Do you want Acrobat to 
detect form fields  for you?” results in the automatic detection of form fields prior to placing 
the document in Form Editing  Mode. This is the same as if you had proceeded using the Form 
Wizard on the current PDF. 

Acrobat completes its analysis of the document, adds any form fields it may detect and places 
the PDF form  in Forms Editing Mode where you can edit the automatically created fields or add 
additional form fields (See “Forms Editing Mode” on page 6).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It 
may have also created fields of the wrong type. Please verify the fields and field names on your 
form. You can select Add New Field on the Forms Editing toolbar to add more fields or right click 
on the form to edit or delete fields.

Answering “No” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect 
form fields for you?” also places the document in Form Editing mode, but does not create form 
fields automatically. You will have to add the form fields manually. Proceed to the next section, 
“Create Form Fields Manually” on page 5 for futher information.

Figure 4.  Acrobat X Pro Add or Edit Form Fields Dialog

Create Form Fields Manually
To add form fields manually do the following:

•	 From the Acrobat Menu. Select View > Tools > Forms and select the Edit 
command under the Forms Tool Pane (Keyboard shortcut is Shift + Ctrl 7). 
This displays the Add or Edit Form Fields dialog (See “Figure 2. Acrobat X 
Pro Create or Edit Form Dialog” on page 3). 

•	 Select the Edit Command > (Keyboard shortcut is Shift + Ctrl 7) and 
answer “No” to the question “Do you want Acrobat to detect Form Fields 
for you?”  (See “Figure 2. Acrobat X Pro Create or Edit Form Dialog” on 
page 3). This places the document in Forms Editing Mode without 
automatically creating any fields. 
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•	 You can now add new form fields to the PDF form by selecting one of 
the options from the Add New Field Command. This is a drop down 
menu that presents the 8 Acrobat field types. Proceed to the next section 
“Forms Editing Mode” on page 6 for further instruction.

Forms Editing Mode
With the PDF form in Forms Editing Mode, you can add new fields and buttons to the form and 
edit or delete any existing field or button. The Acrobat X User Interface changes when in Forms 
Editing Mode (See “Figure 3. Adobe Acrobat X Forms Editing Mode” on page 4). 

•	 A Forms Editing Toolbar provides access to the Select Object tool, the 
Add New Field button, and the Form Preview button. You can configure 
the Add New Field button to display the Forms tools on the toolbar 
instead of the Add New Field button if you prefer.

•	 On the right hand side of the Forms Editing Toolbar, beneath the 
Tasks pane, the Add New Field Command, Distribute Command, Track 
Command, Close Form Command, and Other Tasks Command are 
displayed under the Tasks panel. 

•	 A fields panel appears below the Tasks panel showing any interactive 
fields that are currently part of the form.

Creating a New Form Field

In Acrobat X Pro, you create a form field by choosing one of the form tools. For each field type, 
you can set a variety of options through the form field Properties dialog box. 

You can access the forms tools one of three ways.

•	 You can select “Add New Field” under the task panel (See “Figure 5. 
Adobe Acrobat X Add New Field Command” on page 6). 

Figure 5.  Adobe Acrobat X Add New Field Command
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•	 You can select one of the Forms Tools icon from the Forms Tool Bar 
that appears below the Acrobat X Pro menu bar (See “Figure 6. Adobe 
Acrobat X Forms Tools Icons” on page 7).

Figure 6.  Adobe Acrobat X Forms Tools Icons

•	 You can right click over the form to present options that allow you to add, 
edit, or delete fields (See “Figure 7. Adobe Acrobat X Right Click Forms 
Dialog” on page 7). 

Figure 7.  Adobe Acrobat X Right Click Forms Dialog

Adobe Acrobat X Forms Editing Mode

Once you have selected a form tool, the cursor becomes a cross hair and a light blue region  
defines the outline of the form object you have selected for placement.

•	 On the page, click where you want to add the field to create a field with 
the default size. To create a field using a custom size, drag a rectangle to 
define the size of the field. 

•	 In the Field Name box, type the name of the field, if you want to change it 
from the default name that Acrobat provides.  Acrobat provides a default 
name based upon the field type and the number of fields drawn on the 

7Adobe Acrobat X  Accessibility Accessible PDF Forms



page. You should choose a name that is relevant and descriptive to make 
organizing and collecting the data easier (See “Figure 8. Field Name Box” 
on page 8). 

•	 At this point you can also specify if you want the field to be a required 
field. To display the Properties dialog box and modify any other field 
properties, click Show All Properties (See “Figure 8. Field Name Box” on 
page 8).

Note: 	 If you have checked the “Keep Tool Selected” option in the forms toolbar, the 
Field Name box doesn’t appear after adding a field. Each time you click the page, 
a new field is added to the form. To exit this mode, press the Esc key or click the 
Select Object Tool button. To modify the properties of the field, double-click the 
field. .

Figure 8.  Field Name Box

To test your form, click the Preview button at the top of the document window. Previewing a 
form allows you to view the form the same way the form recipients will see it and gives you a 
chance to verify the appearance and behavior of the form. If you are previewing a form, you can 
click the Edit Layout button to return to Forms Editing mode. 

Form Field Properties
How a form field behaves is determined by settings in the Properties dialog box for that 
individual field. You can set properties that apply formatting, determine how the form field 
information relates to other form fields, impose limitations on what the user can enter in the 
form field, trigger custom scripts, and so forth.

You can set a variety of properties for an Acrobat form field, depending on the form field type. 
The properties for each type of form field are selected on a series of tabs. When you change a 
property, it is applied as soon as you select another property or press Enter.

All the form field types have a General tab, Appearance tab, and an Actions tab. Other tabs 
appear only in specific types of form fields. The Options tab appears for most form field types 
but the options available are unique to each type of form field.

If you are changing the properties of multiple fields, you can leave the Properties dialog box 
open. Click on each field to change its properties.
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Tooltips for Form Fields

For accessibility, the Tooltip option on the General tab is important for entering text that will be 
announced by screen readers.

You can make form fields accessible to people with disabilities by adding tags to the PDF and 
by properly structuring it. In addition, you can use the tool tip form field property to provide the 
user with information about the field or to provide instructions. For example, using the tool tip 
property value, the screen reader could say “Your first name.” Without the tool tip property, a 
screen reader announces the type and name of the form field (See “Figure 9. Adding a Tooltip 
to a Form Field” on page 9).

•	 If necessary, choose Forms > Add or Edit Fields, and make sure that the 
Select Object tool is selected. 

•	 Double-click a selected form field to open the Properties window. 

•	 In the General tab, type a description into the tool tip box. 

The Tooltip also displays text that users may find helpful in filling in the form field. Tooltips 
appear when the pointer hovers briefly over the form field. 

Figure 9.  Adding a Tooltip to a Form Field

Tooltips for Radio Buttons

To create a set of mutually exclusive Radio Buttons, where only one field can be selected at 
a time, give each field the same name and the same Tooltip, but different Button values. The 
Button value is a field in the options tab of the Radio Button Properties dialog 

To make a radio button accessible, in addition to entering unique text in the Button Value field 
for each choice, you would enter identical text in the Tooltip field of the General properties tab 
for each radio button in the group (See “Figure 10. Identical Button Name and Tool Tip Value 
for a Radio Button Group” on page 10).

For example, you may need to create a radio button group that asks the question, “Do You Need 
a Hotel Room Reservation?”
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•	 You would create two radio buttons. For each button, you might choose 
to give the button the identical name, “Hotel Reservation.” For each 
button, you would enter identical  text in the Tooltip field, such as “Do 
You Need a Hotel Room Reservation?” (See “Figure 10. Identical Button 
Name and Tool Tip Value for a Radio Button Group” on page 10). 

Figure 10.  Identical Button Name and Tool Tip Value for a Radio Button Group

•	 For the button next to the label indicating Yes, you would enter “Yes” in 
the Button Value field under the options tab (See “Figure 11. Setting One 
Radio Button in a Group to Indicate “Yes”” on page 11). For the other, 
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the one next to the No label, you would enter “No” in the Button Value 
field (See “Figure 12. Setting One Radio Button in a Group to Indicate 
“No”” on page 11).

Figure 11.  Setting One Radio Button in a Group to Indicate “Yes”

Figure 12.  Setting One Radio Button in a Group to Indicate “No”

Editing or Modifying an Existing Form Field
You can access Acrobat form field properties only when you are in editing mode (by choosing 
Forms > Add Or Edit Fields). You can change the properties for multiple form fields at a time. 

Open the Properties dialog box using one of the following methods: 

•	 To edit a single form field, double-click it or right-click/Control-click it and 
choose Properties. 

•	 To edit multiple form fields, select the fields that you want to edit, right-
click/Control-click one of the selected fields, and choose Properties. 

Change the properties on each of the available tabs, as needed. The property is changed as soon 
as you select another property or press Enter.

•	 Click Close to close the Properties dialog box. 
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If you select form fields that have different property values, some options in the Properties 
dialog box are not available. Otherwise, changes to the available options are applied to all 
selected form fields. 

To avoid accidental changes to the form field, select Locked in the lower left corner of the 
Properties dialog box before you close it. To unlock, click the check box again.

Deleting a Form Field

With the document in Forms Editing mode, click on the field you would like to delete and do any 
of the following.

•	 Right mouse click and select delete

•	 Press the delete key.

•	 From the menu, select Edit > Delete (ALT + ED)

Note: 	 You can select multiple fields by holding the Control key as you click on each 
one.

Buttons
Buttons are most commonly associated with forms, but you can add them to any document. 
Buttons can open a file, play a sound or movie clip, submit data to a web server, and much 
more. When deciding on how to initiate an action, remember that buttons offer the following 
capabilities that links and bookmarks do not:

•	 A button can activate a single action or a series of actions.

•	 A button can change appearance in response to mouse actions.

•	 A button can be easily copied across many pages.

•	 Mouse actions can activate different button actions. For example, 
Mouse Down (a click), Mouse Up (releasing after a click), Mouse Enter 
(moving the pointer over the button), and Mouse Exit (moving the pointer 
away from the button) can all start a different action for the same button.

Buttons are an easy, intuitive way to let users initiate an action in PDF documents. Buttons are 
added the same way as form fields while in Forms Editing mode. They also should be given a 
name and a Tooltip and their behavior is determined by the actions the user assigns the button 
on the actions tab of the Button Properties dialog. They also appear in the Tab order tree. See 
the Adobe Acrobat Help for a complete discussion of PDF fields and buttons.

Set the Tab Order
If a PDF document doesn’t have a specified tab order, the default tabbing order is based on the 
document structure unless the user has deselected the Tab Order option in the Accessibility 
preferences.

You can change the tabbing order after you create the fields. 

•	 If you are in Forms Editing mode, you can order the tabs by document 
structure (default), row, or column. 

•	 You can also choose the order manually by dragging and dropping fields 
in the Fields panel. 
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•	 If you are not in Forms Editing mode, you can change the page properties 
to order the tabs by row or column. However, you can’t customize the tab 
order manually.

To change the tab order, first select “Order Tabs Manually” from the Tab Order button on the 
Fields panel. Then you can drag and drop fields where you want them within the Fields panel to 
modify the tab order (See “Figure 13. Rearranging Tab Order with the Fields Panel” on page 
13). To assist in determining tab order, you can select “Show Tab Numbers” from the Tab 
Order button of the Fields panel (See “Figure 13. Rearranging Tab Order with the Fields Panel” 
on page 13).

In the example shown in Figure 13 on page 13, Text Field 1 “District” is in the second position 
though it should be first. Text Field 2, “Date Due” is in the first position, though it should be 
second. Selecting the entry for Text2 in the Forms panel highlights the corresponding field in the 
document view. To move it to the second position, drag it down and drop it below the entry for 
Text1 (or you could pushed Text1 up above Text2).  Refer to “Figure 13. Rearranging Tab Order 
with the Fields Panel” on page 13 to see the relationship between items in the Fields Panel 
and the Document pane. Note also the Order Tabs Manually and the Show Tab Numbers options 
are highlighted.

Figure 13.  Rearranging Tab Order with the Fields Panel

Add Other Accessibility Features
This stage includes setting the document language, making sure that security settings do not 
interfere with screen readers, creating accessible links, adding tags to the document and adding 
bookmarks. There may be other tasks to complete on your file before it can be considered 
accessible. For a discussion on how to proceed from this point, refer to the document Adobe® 
Acrobat® X Pro Accessibility Guide: PDF Accessibility Repair Workflow.
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For more information
Solution details: www.adobe.com/accessibility/products/acrobat/
Program details: www.adobe.com/accessibility
Contact information: access@adobe.com
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